Undated · 15 versions
1.19.6
Latest1 fix1 security
Fixed- Address PHP 8.4 deprecation warnings caused by implicitly nullable `$order` parameters
Security- Improve validation of order ownership on pay page requests
Fixed- Address PHP 8.2 deprecation warnings caused by dynamic properties on the $order object
Changes- Misc - Note that the Secure API Token setting will become required in the next plugin version, and warn merchants who haven't configured it
Fixed- Secure handling of IPN and AJAX order-status callbacks
1.19.3
1 security1 change
Security- Hardened capability checks around the payment token editor's admin functionality
Changes- Misc - Updated the SkyVerge Plugin Framework to v6.2.4
1.19.2
2 fixes2 changes
Fixed- Replace usage of deprecated `wc_enqueue_js` function
- Resolve `_load_textdomain_just_in_time` doing-it-wrong notices
Changes- Misc - Tested up to WooCommerce 10.5.3
- Misc - Updated the SkyVerge Framework to v6.2.2
Changes- Misc - Tested up to WooCommerce 10.2
- Misc - Improve escaping and sanitizing throughout codebase
- Misc - Update the SkyVerge Framework to v5.15.12
New- Add support for the Checkout block
Changes- Misc - Improve compatibility with PHP 8.2+
Changes- Misc - Add admin notice to help merchants reverting to the checkout shortcode if the checkout block is used
- Localization - Improve the plugin localization of components that are part of the underlying framework dependency
Changes- Misc - Add compatibility for WooCommerce High Performance Order Storage (HPOS)
- Misc - Improve Accepted Cards setting description
Fixed- Resolve bug when deleting a saved credit card
Changes- Misc - Update SkyVerge Plugin Framework to 5.10.15
- Misc - Require PHP 7.4 and WordPress 5.6
Fixed- Fix bug with manual renewal of subscription renewals
- Fix bug with using a saved payment method to check out
1.16.3
2 fixes1 change
Fixed- Ensure that Auth/Capture orders placed while Certification Mode is enabled aren't placed on hold
- Replace deprecated `is_ajax` function calls with `wp_doing_ajax`
Changes- Misc - Require WooCommerce 3.9.4 or greater
Fixed- Ensure WooCommerce Subscriptions or Pre-Orders are active before calling their methods while forcing tokenization
Changes- Misc - Remove legacy woo-includes folder
Fixed- Force tokenization when paying for an order containing a subscription or pre-order
Changes- Misc - Add compatibility for WooCommerce 4.7
- Misc - Require PHP 7.0 or newer
Changelog published by the developer, in their original language.