Sem data · 15 versões
3.5.0
Última1 correção
Corrigido- Address PHP 8.2 deprecation warnings caused by dynamic properties on the $order object
Melhoria- Improve handling of Intuit account connection requests
- The legacy `WC_Intuit_Payments::decrypt_credential_legacy` method is now non-functional and will be entirely removed in a future version
Segurança- Hardened capability checks around the payment token editor's admin functionality
Alterações- Misc - Updated the SkyVerge Plugin Framework to v6.2.4
3.3.3
1 correção1 alteração
Corrigido- Addressed `wc_enqueue_js` deprecation warnings
Alterações- Misc - Updated the SkyVerge Plugin Framework to v6.2.3
3.3.2
3 correções1 alteração
Corrigido- "Translations loaded too early" error
- Classic checkout: card CSC field not appearing for saved cards when "Saved Card Security Code" is checked on
- Ensure all strings with placeholders have corresponding "translator" comments
Alterações- Misc - Update the SkyVerge Plugin Framework to v5.15.12
3.3.1
1 correção2 alterações
Corrigido- Explicitly mark nullable parameters as such, to address deprecation warnings
Alterações- Misc - Tested up to WooCommerce 10.2
- Misc - Improve escaping and sanitizing throughout codebase
Novo- Simplify connecting to QuickBooks Payments by removing the need to create an app in the Intuit Developer Portal
- Add support to the WooCommerce Checkout block
Melhoria- Fix a typo in gateway class names and add alias for backwards compatibility
Alterações- Misc - Remove onboarding wizard
Alterações- Misc - Add admin notice to help merchants reverting to the checkout shortcode if the checkout block is used
- Localization - Improve the plugin localization of components that are part of the underlying framework dependency
Alterações- Misc - Add compatibility for WooCommerce High Performance Order Storage (HPOS)
3.1.2
1 correção1 alteração
Corrigido- Resolve bug when deleting a saved credit card
Alterações- Misc - Update SkyVerge Plugin Framework to 5.10.15
Corrigido- Loading of payment gateway setup wizard files
3.1.0
1 correção2 alterações
Corrigido- Replace deprecated `is_ajax` function calls with `wp_doing_ajax`
Alterações- Misc - Require WooCommerce 3.9.4 or higher
- Misc - Require PHP 7.4 and WordPress 5.6
Alterações- Misc - Remove the legacy QBMS gateway
Alterações- Misc - Add compatibility for WooCommerce 4.7
- Misc - Require PHP 7.0 or newer
Alterações- Misc - Add support for PHP 8
Changelog publicado pelo desenvolvedor, no idioma original.